Page MenuHomeGitPull.it

Problema dopo installazione dual-boot Ubuntu-Windows, impossibile avviare Windows 10
Open, NormalPublic

Description

Buongiorno, ho un problemino con l’avvio del pc, un Packard Bell imedia s 1800, sul quale ho installato in partizione di disco (credo di aver eseguito tutto secondo descrizione del sito ufficiale) Ubuntu 16, volendomi avvicinare al vostro OS, con il Windows 10. Quando però avvio il computer anche scegliendo l’opzione Windows dal Grub non mi inizializza quest’ultimo è mi fa partire solo Ubuntu. Ho guardato diversi articoli su internet ma non trovo in questo caso specifico nulla che mi possa aiutare.
Un’altra domanda, io uso il pc con l’hotspot del cellulare tramite ricevitore Bluetooth usb, come faccio a far rilevare al OS di Linux la chiavetta per poter utilizzare internet?
Grazie e cordiali saluti
Paolo.
Allego foto della schermata di avvio[Image.jpeg]

Scarica Outlook per iOShttps://aka.ms/o0ukef

Event Timeline

valerio.bozzolan added a subscriber: valerio.bozzolan.

Ciao Paolo!

Grazie per averci scritto. Siamo tutti volontari comunque scusaci per il ritardo.

Dato il tuo problema possiamo provare a fare alcune assunzioni:

  • che Windows è installato e configurato per fare il boot via UEFI
  • che Ubuntu è configurato e installato per fare boot via UEFI

Se ciò non fosse il mio consiglio forse non risolverà nulla.

Copia questo comando (usa pure il mouse, seleziona il comando qui in basso, tasto destro → copia):

sudo -H gedit /boot/grub/custom.cfg

Poi cerca fra le applicazioni "Emulatore di terminale" e incolla il comando e premi invio.

Ti chiederà la tua password. Inseriscila (non la mostrerà a schermo). Premi INVIO.

Ricomincia da capo finchè non funziona.

A questo punto si aprirà un editor di testo. Puoi inserire dentro questo contenuto da poter copiare e incollare:

#This entry should work for any version of Windows installed for UEFI booting

menuentry "Windows (UEFI)" {
 search --set=root --file /EFI/Microsoft/Boot/bootmgfw.efi
 chainloader /EFI/Microsoft/Boot/bootmgfw.efi
}

Ora salva, chiudi tutto e riavvia il sistema.

All'avvio dovresti vedere una voce chiamata "Windows (UEFI)" e dovresti poterla selezionare. Se non funziona abbiamo bisogno di maggiori dettagli.

In che città vivi? Possiamo metterti in contatto con un gruppo utenti locale nella tua città per provare a vedere se nonostante il COVID-19 riusciamo a farti assistenza?

Facci sapere ciau :)

(La tua soluzione è meglio dettagliata nel prossimo link. L'ho tradotta in licenza CC BY-SA 4.0.)

https://askubuntu.com/questions/217904/unable-to-boot-into-windows-after-installing-ubuntu-how-to-fix

Facci sapere ciau! :)

valerio.bozzolan renamed this task from Problemi con i boot to Problema dopo installazione dual-boot Ubuntu-Windows, impossibile avviare Windows 10.Apr 14 2021, 08:08
valerio.bozzolan triaged this task as Normal priority.
valerio.bozzolan updated the task description. (Show Details)

Buongiorno Valerio, innanzitutto grazie per aver risposto alla mia richiesta di aiuto e mi scuso del ritardo seguente per la mia risposta ma tra l’attesa per la tua e il riprendere a lavorare avevo abbandonato il mio progetto Linux perché effettivamente mi portava via parecchio tempo (non è un SO per tutti effettivamente).
Ora ho ricominciato a fare alcune prove e ho messo in pratica la tua soluzione: tutto come hai detto tu, purtroppo nonostante anche la voce “Windows uefi” sia comparsa il Windows non ha inizializzato. Ti mando la foto della schermata a seguito riavvio dopo l’esecuzione dei comandi che mi hai dato.
Per il resto io abito a Pinerolo in provincia di Torino, nel caso ci fosse qualcuno operativo qua in zona lo contatto anche volentieri visto che tra i miei conoscenti nessuno sembra sappia nulla di Ubuntu purtroppo...

error: no such device: /EFI/Microsoft/Boot/bootmgfw.efi
error: file `/EFI/Microsoft/Boot/bootmgfw.efi' not found.
Press any key to continue...

Ciao Paolo!

Credo che questo problema si risolva come specificato in questo commento:

https://askubuntu.com/a/1318980

Cioè inserire una chiavetta con Microsoft Windows (bleah) nel computer all'avvio e usare il suo menù:

"Repair your computer" > Troubleshoot > Startup Repair.

Per risolvere il problema ci sono anche altre soluzioni e mi sto confrontando con altri nel frattempo per cercare di capire quale possa essere la causa più plausibile e la risoluzione più semplice.

Questa operazione che ho citato, se hai fretta, un negozio di elettronica o un negozio di cinesi o un parente smanettone dovrebbe poterla fare in mezz'ora di lavoro. Ti segnalo anche l'officina informatica libera di Torino se hai la possibilità di venire un mercoledì dalle 18:00 alle 20:00 mandandoci prima una mail:

https://informaticalibera.info/

Va bene se mi prendo ancora un po' di tempo per darti altre risposte?

Fammi sapere se va già bene così

Grazie mille per la pazienza!

Prima di provare quella cosa, il mio amico G1bot mi suggerisce di
entrare in Ubuntu, aprire l'applicazione chiamata "Emulatore di
terminale", e copiare e incollare questi comandi nel terminale (fare
copia-incolla con il menù del mouse del tasto destro, per evitare
problemi):

sudo -i
os-prober
grub-mkconfig -o /boot/grub/grub.cfg

Dopo ognuno di questi comandi, premere INVIO e lanciare il prossimo.

Il primo comando è un po' particolare perchè ti chiederà subito la password del tuo utente. Digitala. Non te la mostrerà sullo
schermo. Poi premi INVIO. Se giusta continua con gli altri comandi, sennò riprova.

Fammi sapere :-)

Allora, ho provato la soluzione di G1bot (carino il nick 🤣) e sembra funzionare dicendomi che sono stati trovati i file di Windows nel sda4, però dopodiché se provo a chiudere il terminale mi dice che la sessione è ancora aperta e che se la chiudo perderò tutti i dati. Ho provato ad integrarla dopo con la prima soluzione da te indicata, quella ove apre l’editor di testo, ma mi ha aggiunto una seconda voce “Windows (uefi)” nel bios e che non funziona di nuovo. Nel Bios ho la voce “Windows recovery environment (su/dev/sda4)” ma se la avviassi per il ripristino del Windows precedente perderei l’aggiornamento al 10 per ritornare al 8 (e ora non fanno più aggiornare gratuitamente) ma poi non andrebbe a cancellare anche la partizione di Ubuntu? Domani pomeriggio preparerò la chiavetta iso di Windows 10 per provare la tua seconda indicazione, però, domanda: all’avvio “Repair your computer" > Troubleshoot > Startup Repair., dove lo trovo? Nel senso mi esce come voce sul bios?
Grazie ancora, e grazie per l’invito in officina, complimenti per il lavoro che fate, mi affascina Linux per un discorso di “alternativa” e per l’ideologia del progetto, spero di imparare almeno quanto basta per poterlo sfruttare al meglio.
Saluti Valerio e grazie ancora.

Screenshot_20210915_164408.png (571×1 px, 957 KB)